# CVE-2009-0662: Moderate severity vulnerability that affects Products.PlonePAS

> Authenticated users can impersonate arbitrary users in PlonePAS due to improper login form handling, leading to privilege escalation.

- **Severity:** Medium 6.0 (`AV:N/AC:M/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-pq3x-96c3-xgjg, PYSEC-2009-17, PYSEC-2026-739

## What is CVE-2009-0662?

CVE-2009-0662 is a medium-severity authentication bypass vulnerability in n/a, published on 23 Apr 2009. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The PlonePAS product 3.x before 3.9 and 3.2.x before 3.2.2, a product for Plone, does not properly handle the login form, which allows remote authenticated users to acquire the identity of an arbitrary user via unspecified vectors.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2009-0662?

4 open source packages ship an affected version, including products-plonepas, Products.PlonePAS and plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `products-plonepas` | PyPI | From 3 | 3.9 |
| `products-plonepas` | PyPI | From 3 | 3.9 |
| `Products.PlonePAS` | PyPI | From 3 | 3.9 |
| `plone` | PyPI | From 3.0 to 3.1 | None |

Products: Plone Plonepas.

## How do I fix CVE-2009-0662?

Upgrade products-plonepas to 3.9 or later.

## Is CVE-2009-0662 being exploited?

There is no known exploitation of CVE-2009-0662 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-0662 and fix it if it is affected.

What it is: CVE-2009-0662 is a medium-severity authentication bypass vulnerability in n/a, published on 23 Apr 2009. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-0662 in the wild and no public exploit code.

Affected packages and fixed versions:
- products-plonepas (PyPI): affected from 3; fixed in 3.9
- products-plonepas (PyPI): affected from 3; fixed in 3.9
- Products.PlonePAS (PyPI): affected from 3; fixed in 3.9
- plone (PyPI): affected from 3.0 up to 3.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-0662/ (Markdown: https://insights.sbomify.com/CVE-2009-0662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-0662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-0662
- OSV: https://osv.dev/vulnerability/CVE-2009-0662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-0662/
Summaries are generated and may contain mistakes; the official description above is the record.
