# CVE-2009-0668: Zope Object Database (ZODB) vulnerable to arbitrary Python code execution in ZEO storage servers


- **Severity:** Medium 6.5 (`AV:N/AC:L/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Aug 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-4x83-5gw5-q346, PYSEC-2009-8

## What is CVE-2009-0668?

CVE-2009-0668 is a medium-severity vulnerability in n/a, published on 7 Aug 2009. 

### Official description

Unspecified vulnerability in Zope Object Database (ZODB) before 3.8.2, when certain Zope Enterprise Objects (ZEO) database sharing is enabled, allows remote attackers to execute arbitrary Python code via vectors involving the ZEO network protocol.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2009-0668?

3 open source packages ship an affected version, including zodb3 and ZODB3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zodb3` | PyPI | All versions | 3.8.2 |
| `zodb3` | PyPI | All versions | 3.8.2 |
| `ZODB3` | PyPI | All versions | 3.8.2 |

Products: Zope Zodb.

## How do I fix CVE-2009-0668?

Upgrade zodb3 to 3.8.2 or later.

## Is CVE-2009-0668 being exploited?

There is no known exploitation of CVE-2009-0668 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2009-0669](https://insights.sbomify.com/CVE-2009-0669/): Zope Object Database (ZODB) Authentication bypass in ZEO storage servers (high 7.5)
- [CVE-2009-2701](https://insights.sbomify.com/CVE-2009-2701/): Zope Object Database (ZODB) Arbitrary files reading and deletion (medium 6.0)
- [CVE-2010-3495](https://insights.sbomify.com/CVE-2010-3495/): Zope Object Database Denial of Service vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-0668 and fix it if it is affected.

What it is: CVE-2009-0668 is a medium-severity vulnerability in n/a, published on 7 Aug 2009. 
Exploitation: There is no known exploitation of CVE-2009-0668 in the wild and no public exploit code.

Affected packages and fixed versions:
- zodb3 (PyPI): affected all versions; fixed in 3.8.2
- zodb3 (PyPI): affected all versions; fixed in 3.8.2
- ZODB3 (PyPI): affected all versions; fixed in 3.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-0668/ (Markdown: https://insights.sbomify.com/CVE-2009-0668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-0668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-0668
- OSV: https://osv.dev/vulnerability/CVE-2009-0668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-0668/
Summaries are generated and may contain mistakes; the official description above is the record.
