# CVE-2009-0781: Cross-site scripting in Apache Tomcat

> Remote attackers can inject arbitrary web script via the time parameter in the Tomcat examples calendar application, requiring user interaction.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Mar 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-j788-fx57-99wp

## What is CVE-2009-0781?

CVE-2009-0781 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 9 Mar 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in jsp/cal/cal2.jsp in the calendar application in the examples web application in Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 allows remote attackers to inject arbitrary web script or HTML via the time parameter, related to "invalid HTML."

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2009-0781?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 to 4.1.39 | None |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 to 4.1.39 | None |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 to 5.5.27 | None |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 to 5.5.27 | None |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.20 |

Products: Apache Tomcat.

## How do I fix CVE-2009-0781?

Upgrade org.apache.tomcat:tomcat to 6.0.20 or later.

## Is CVE-2009-0781 being exploited?

There is no known exploitation of CVE-2009-0781 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-0781 and fix it if it is affected.

What it is: CVE-2009-0781 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 9 Mar 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2009-0781 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0 up to 4.1.39; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0 up to 4.1.39; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0 up to 5.5.27; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0 up to 5.5.27; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.20
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-0781/ (Markdown: https://insights.sbomify.com/CVE-2009-0781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-0781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-0781
- OSV: https://osv.dev/vulnerability/CVE-2009-0781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-0781/
Summaries are generated and may contain mistakes; the official description above is the record.
