# CVE-2009-0783: Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat

> Local users can read or modify configuration files of other web applications by replacing the shared XML parser in Apache Tomcat.

- **Severity:** Medium 4.2 (`CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-hhjg-g8xq-hhr3

## What is CVE-2009-0783?

CVE-2009-0783 is a medium-severity vulnerability in Apache Tomcat, published on 5 Jun 2009. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18 permits web applications to replace an XML parser used for other web applications, which allows local users to read or modify the (1) web.xml, (2) context.xml, or (3) tld files of arbitrary web applications via a crafted application that is loaded earlier than the target application.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2009-0783?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 to 4.1.39 | None |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 to 4.1.39 | None |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 to 5.5.27 | None |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 to 5.5.27 | None |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.20 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.20 |

Products: Apache Tomcat.

## How do I fix CVE-2009-0783?

Upgrade org.apache.tomcat:tomcat to 6.0.20 or later.

## Is CVE-2009-0783 being exploited?

There is no known exploitation of CVE-2009-0783 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-0783 and fix it if it is affected.

What it is: CVE-2009-0783 is a medium-severity vulnerability in Apache Tomcat, published on 5 Jun 2009. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-0783 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0 up to 4.1.39; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0 up to 4.1.39; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0 up to 5.5.27; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0 up to 5.5.27; no fix listed
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.20
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-0783/ (Markdown: https://insights.sbomify.com/CVE-2009-0783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-0783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-0783
- OSV: https://osv.dev/vulnerability/CVE-2009-0783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-0783/
Summaries are generated and may contain mistakes; the official description above is the record.
