CVE-2009-0816 Typo3 Backend XSS Vulnerability
Remote attackers can inject arbitrary web script or HTML into the TYPO3 backend interface, potentially compromising user sessions and data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2009-0816?
CVE-2009-0816 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 5 Mar 2009. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in the backend user interface in TYPO3 3.3.x through 3.8.x, 4.0 before 4.0.12, 4.1 before 4.1.10, 4.2 before 4.2.6, and 4.3alpha1 allow remote attackers to inject arbitrary web script or HTML via unspecified fields.
Weakness: CWE-79
Which versions are affected by CVE-2009-0816?
10 open source packages ship an affected version, including typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | All versions | None |
typo3/cms Packagist | All versions | None |
typo3/cms Packagist | From 3.3.0 | None |
typo3/cms Packagist | From 3.3.0 | None |
typo3/cms Packagist | From 4.0 | 4.0.12 |
typo3/cms Packagist | From 4.0 | 4.0.12 |
4 more packages
typo3/cms Packagist | From 4.1.0 | 4.1.10 |
typo3/cms Packagist | From 4.1.0 | 4.1.10 |
typo3/cms Packagist | From 4.2.0 | 4.2.6 |
typo3/cms Packagist | From 4.2.0 | 4.2.6 |
Products include Typo3 Typo3.
How do I fix CVE-2009-0816?
Upgrade typo3/cms to a fixed version for your release line: 4.0.12, 4.1.10 or 4.2.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2009-0816 being exploited?
There is no known exploitation of CVE-2009-0816 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-jg55-3q6h-2ccf.