{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2009-10001 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2009-10001 yet. Limit exposure of the affected software until one is available.","what":"CVE-2009-10001 is a low-severity cross-site scripting vulnerability in jianlinwei cool-php-captcha, published on 13 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2009-10001 and fix it if it is affected.\n\nWhat it is: CVE-2009-10001 is a low-severity cross-site scripting vulnerability in jianlinwei cool-php-captcha, published on 13 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2009-10001 in the wild and no public exploit code.\n\nAffected product: jianlinwei cool-php-captcha. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-10001/ (Markdown: https://insights.sbomify.com/CVE-2009-10001/index.md)","id":"CVE-2009-10001","markdown":"https://insights.sbomify.com/CVE-2009-10001/index.md","name":"CVE-2009-10001","record":{"aliases":["GHSA-7rxf-234p-2f7w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP captcha library","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary scripts in a victim's browser via the captcha argument in the example form of the cool-php-captcha library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"cool-php-captcha","vendor":"cool-php-captcha_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability classified as problematic was found in jianlinwei cool-php-captcha up to 0.2. This vulnerability affects unknown code of the file example-form.php. The manipulation of the argument captcha with the input %3Cscript%3Ealert(1)%3C/script%3E leads to cross site scripting. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.3 is able to address this issue. The name of the patch is c84fb6b153bebaf228feee0cbf50728d27ae3f80. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218296.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"jianlinwei cool-php-captcha example-form.php cross site scripting","id":"CVE-2009-10001","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2009"},"n_packages":0,"n_references":5,"next":{"headline":"dpup fittr-flickr EXIF Preview easy-exif.js cross site scripting","id":"CVE-2009-10002"},"packages":[],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2009-5159"},"products":["cool-php-captcha"],"published":"2023-01-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["jianlinwei"]},"summary":"An attacker can execute arbitrary scripts in a victim's browser via the captcha argument in the example form of the cool-php-captcha library.","url":"https://insights.sbomify.com/CVE-2009-10001/"}