{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2009-10003 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2009-10003 yet. Limit exposure of the affected software until one is available.","what":"CVE-2009-10003 is a low-severity vulnerability in capnsquarepants wordcraft, published on 29 Jan 2023."},"fix_prompt":"Check this codebase for CVE-2009-10003 and fix it if it is affected.\n\nWhat it is: CVE-2009-10003 is a low-severity vulnerability in capnsquarepants wordcraft, published on 29 Jan 2023. \nExploitation: There is no known exploitation of CVE-2009-10003 in the wild and no public exploit code.\n\nAffected product: capnsquarepants wordcraft. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-10003/ (Markdown: https://insights.sbomify.com/CVE-2009-10003/index.md)","id":"CVE-2009-10003","markdown":"https://insights.sbomify.com/CVE-2009-10003/index.md","name":"CVE-2009-10003","record":{"aliases":["GHSA-qvv5-hfwv-7qf8"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"wordcraft","vendor":"wordcraft_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in capnsquarepants wordcraft up to 0.6. It has been classified as problematic. Affected is an unknown function of the file tag.php. The manipulation of the argument tag leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 0.7 is able to address this issue. The patch is identified as be23028633e8105de92f387036871c03f34d3124. It is recommended to upgrade the affected component. VDB-219714 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"capnsquarepants wordcraft tag.php cross site scripting","id":"CVE-2009-10003","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2009"},"n_packages":0,"n_references":4,"next":{"headline":"Turante Sandbox Theme functions.php sandbox_body_class cross site scripting","id":"CVE-2009-10004"},"packages":[],"prev":{"headline":"dpup fittr-flickr EXIF Preview easy-exif.js cross site scripting","id":"CVE-2009-10002"},"products":["wordcraft"],"published":"2023-01-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-07","vendors":["capnsquarepants"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2009-10003/"}