# CVE-2009-10003: capnsquarepants wordcraft tag.php cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Jan 2023
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-qvv5-hfwv-7qf8

## What is CVE-2009-10003?

CVE-2009-10003 is a low-severity vulnerability in capnsquarepants wordcraft, published on 29 Jan 2023. 

### Official description

A vulnerability was found in capnsquarepants wordcraft up to 0.6. It has been classified as problematic. Affected is an unknown function of the file tag.php. The manipulation of the argument tag leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 0.7 is able to address this issue. The patch is identified as be23028633e8105de92f387036871c03f34d3124. It is recommended to upgrade the affected component. VDB-219714 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2009-10003?

It affects 1 product.


Products: Wordcraft Project Wordcraft.

## How do I fix CVE-2009-10003?

No fix has been published for CVE-2009-10003 yet. Limit exposure of the affected software until one is available.

## Is CVE-2009-10003 being exploited?

There is no known exploitation of CVE-2009-10003 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-10003 and fix it if it is affected.

What it is: CVE-2009-10003 is a low-severity vulnerability in capnsquarepants wordcraft, published on 29 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2009-10003 in the wild and no public exploit code.

Affected product: capnsquarepants wordcraft. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-10003/ (Markdown: https://insights.sbomify.com/CVE-2009-10003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-10003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-10003
- OSV: https://osv.dev/vulnerability/CVE-2009-10003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-10003/
Summaries are generated and may contain mistakes; the official description above is the record.
