# CVE-2009-1264: Frontend User Registration extension for TYPO3 does not properly verify access rights

> Authenticated users can bypass access controls to obtain sensitive information like passwords in the Frontend User Registration extension.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2009
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rjrq-93hp-22ww

## What is CVE-2009-1264?

CVE-2009-1264 is a medium-severity missing authorization vulnerability in n/a, published on 7 Apr 2009. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frontend User Registration (sr_feuser_register) extension 2.5.20 and earlier for TYPO3 does not properly verify access rights, which allows remote authenticated users to obtain sensitive information such as passwords via unknown attack vectors.

Weakness: CWE-264

## Which versions are affected by CVE-2009-1264?

2 open source packages ship an affected version, including sjbr/sr-feuser-register. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sjbr/sr-feuser-register` | Packagist | All versions | 2.5.21 |
| `sjbr/sr-feuser-register` | Packagist | All versions | 2.5.21 |

Products: Stanislas Rolland Sr Feuser Register.

## How do I fix CVE-2009-1264?

Upgrade sjbr/sr-feuser-register to 2.5.21 or later.

## Is CVE-2009-1264 being exploited?

There is no known exploitation of CVE-2009-1264 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2012-5890](https://insights.sbomify.com/CVE-2012-5890/): Front End User Registration (sr_feuser_register) extension for TYPO3 allows remote attackers to obtain user names, passwords (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-1264 and fix it if it is affected.

What it is: CVE-2009-1264 is a medium-severity missing authorization vulnerability in n/a, published on 7 Apr 2009. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-1264 in the wild and no public exploit code.

Affected packages and fixed versions:
- sjbr/sr-feuser-register (Packagist): affected all versions; fixed in 2.5.21
- sjbr/sr-feuser-register (Packagist): affected all versions; fixed in 2.5.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-1264/ (Markdown: https://insights.sbomify.com/CVE-2009-1264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-1264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-1264
- OSV: https://osv.dev/vulnerability/CVE-2009-1264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-1264/
Summaries are generated and may contain mistakes; the official description above is the record.
