# CVE-2009-1275: Apache Tiles Vulnerable to XSS via EL Expression Injection

> Remote attackers can execute cross-site scripting attacks or access sensitive information via double evaluation of Expression Language in Apache Tiles JSP tags.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2009
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2009-1275, GHSA-2c6q-rgvj-66rx

## What is CVE-2009-1275?

CVE-2009-1275 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Apr 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Tiles 2.1 before 2.1.2, as used in Apache Struts and other products, evaluates Expression Language (EL) expressions twice in certain circumstances, which allows remote attackers to conduct cross-site scripting (XSS) attacks or obtain sensitive information via unspecified vectors, related to the (1) tiles:putAttribute and (2) tiles:insertTemplate JSP tags.

## Which versions are affected by CVE-2009-1275?

2 open source packages ship an affected version, including org.apache.tiles:tiles-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tiles:tiles-core` | Maven | From 2.1 | 2.1.2 |
| `org.apache.tiles:tiles-core` | Maven | From 2.1 | 2.1.2 |

Products: Apache Tiles.

## How do I fix CVE-2009-1275?

Upgrade org.apache.tiles:tiles-core to 2.1.2 or later.

## Is CVE-2009-1275 being exploited?

There is no known exploitation of CVE-2009-1275 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-49735](https://insights.sbomify.com/CVE-2023-49735/): Apache Tiles: Unvalidated input may lead to path traversal and XXE (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-1275 and fix it if it is affected.

What it is: CVE-2009-1275 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Apr 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2009-1275 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tiles:tiles-core (Maven): affected from 2.1; fixed in 2.1.2
- org.apache.tiles:tiles-core (Maven): affected from 2.1; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-1275/ (Markdown: https://insights.sbomify.com/CVE-2009-1275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-1275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-1275
- OSV: https://osv.dev/vulnerability/CVE-2009-1275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-1275/
Summaries are generated and may contain mistakes; the official description above is the record.
