# CVE-2009-1523: Directory traversal in Mort Bay Jetty

> Remote attackers can access arbitrary files on the server via directory traversal sequences in the URI of the Jetty HTTP server.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-9986-w5h5-vw59

## What is CVE-2009-1523?

CVE-2009-1523 is a medium-severity path traversal vulnerability in n/a, published on 5 May 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in the HTTP server in Mort Bay Jetty 5.1.14, 6.x before 6.1.17, and 7.x through 7.0.0.M2 allows remote attackers to access arbitrary files via directory traversal sequences in the URI.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2009-1523?

4 open source packages ship an affected version, including org.mortbay.jetty:jetty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.mortbay.jetty:jetty` | Maven | All versions | 6.1.17 |
| `org.mortbay.jetty:jetty` | Maven | All versions | 6.1.17 |
| `org.mortbay.jetty:jetty` | Maven | From 7.0.0.M0 | 7.0.0.M2 |
| `org.mortbay.jetty:jetty` | Maven | From 7.0.0.M0 | 7.0.0.M2 |

Products: Mortbay Jetty.

## How do I fix CVE-2009-1523?

Upgrade org.mortbay.jetty:jetty to a fixed version for your release line: 6.1.17 or 7.0.0.M2.

## Is CVE-2009-1523 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-1523 exists.

Public exploit code:

- Jetty Web Server - Directory Traversal (exploitdb)
- VMware - Update Manager Directory Traversal (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2009-4611](https://insights.sbomify.com/CVE-2009-4611/): Improper input validation in Mort Bay Jetty (high 7.5)
- [CVE-2009-5048](https://insights.sbomify.com/CVE-2009-5048/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2011-4461](https://insights.sbomify.com/CVE-2011-4461/): Improper Input Validation in Jetty (medium 5.3)
- [CVE-2009-4609](https://insights.sbomify.com/CVE-2009-4609/): Information disclosure in n/a (medium 5.0)
- [CVE-2005-3747](https://insights.sbomify.com/CVE-2005-3747/): Mortbay Jetty Discloses JSP Source Code (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-1523 and fix it if it is affected.

What it is: CVE-2009-1523 is a medium-severity path traversal vulnerability in n/a, published on 5 May 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-1523 exists.

Affected packages and fixed versions:
- org.mortbay.jetty:jetty (Maven): affected all versions; fixed in 6.1.17
- org.mortbay.jetty:jetty (Maven): affected all versions; fixed in 6.1.17
- org.mortbay.jetty:jetty (Maven): affected from 7.0.0.M0; fixed in 7.0.0.M2
- org.mortbay.jetty:jetty (Maven): affected from 7.0.0.M0; fixed in 7.0.0.M2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-1523/ (Markdown: https://insights.sbomify.com/CVE-2009-1523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-1523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-1523
- OSV: https://osv.dev/vulnerability/CVE-2009-1523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-1523/
Summaries are generated and may contain mistakes; the official description above is the record.
