# CVE-2009-1595: Ignite Realtime Openfire Allows Users to Change Passwords of Arbitrary Accounts

> Authenticated users can change passwords of arbitrary accounts by modifying the username element in password change requests.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-r62w-x9pp-jrqp

## What is CVE-2009-1595?

CVE-2009-1595 is a medium-severity authentication bypass vulnerability in n/a, published on 11 May 2009. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The jabber:iq:auth implementation in IQAuthHandler.java in Ignite Realtime Openfire before 3.6.4 allows remote authenticated users to change the passwords of arbitrary accounts via a modified username element in a passwd_change action.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2009-1595?

2 open source packages ship an affected version, including org.igniterealtime.openfire:parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.igniterealtime.openfire:parent` | Maven | All versions | 3.6.4 |
| `org.igniterealtime.openfire:parent` | Maven | All versions | 3.6.4 |

Products: Igniterealtime Openfire.

## How do I fix CVE-2009-1595?

Upgrade org.igniterealtime.openfire:parent to 3.6.4 or later.

## Is CVE-2009-1595 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-1595 exists.

Public exploit code:

- Openfire 3.x - jabber:iq:auth 'passwd_change' Remote Password Change (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2023-32315](https://insights.sbomify.com/CVE-2023-32315/): Ignite Realtime Openfire Path Traversal (high 8.6, exploited in the wild)
- [CVE-2024-25421](https://insights.sbomify.com/CVE-2024-25421/): Ignite Realtime Openfire privilege escalation vulnerability (critical 9.8)
- [CVE-2021-45967](https://insights.sbomify.com/CVE-2021-45967/): Path traversal in n/a (critical 9.8)
- [CVE-2019-18394](https://insights.sbomify.com/CVE-2019-18394/): Ignite Realtime Openfire vulnerable to Server Side Request Forgery (critical 9.8)
- [CVE-2014-2741](https://insights.sbomify.com/CVE-2014-2741/): Ignite Realtime Openfire vulnerable to XMPPbomb attack (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-1595 and fix it if it is affected.

What it is: CVE-2009-1595 is a medium-severity authentication bypass vulnerability in n/a, published on 11 May 2009. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-1595 exists.

Affected packages and fixed versions:
- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 3.6.4
- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 3.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-1595/ (Markdown: https://insights.sbomify.com/CVE-2009-1595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-1595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-1595
- OSV: https://osv.dev/vulnerability/CVE-2009-1595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-1595/
Summaries are generated and may contain mistakes; the official description above is the record.
