# CVE-2009-20001: MantisBT Insufficient Session Expiration cookie string not reset after logout

> Attackers can hijack user accounts by reusing session cookies that remain valid after logout, allowing unauthorized access to MantisBT.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2021
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-jm72-67rm-763j

## What is CVE-2009-20001?

CVE-2009-20001 is a high-severity authentication bypass vulnerability in Mantisbt Mantisbt, published on 7 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in MantisBT before 2.24.5. It associates a unique cookie string with each user. This string is not reset upon logout (i.e., the user session is still considered valid and active), allowing an attacker who somehow gained access to a user's cookie to login as them.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2009-20001?

2 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.24.5 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.24.5 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2009-20001?

Upgrade mantisbt/mantisbt to 2.24.5 or later.

## Is CVE-2009-20001 being exploited?

There is no known exploitation of CVE-2009-20001 in the wild and no public exploit code.

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-20001 and fix it if it is affected.

What it is: CVE-2009-20001 is a high-severity authentication bypass vulnerability in Mantisbt Mantisbt, published on 7 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-20001 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.24.5
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.24.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-20001/ (Markdown: https://insights.sbomify.com/CVE-2009-20001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-20001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-20001
- OSV: https://osv.dev/vulnerability/CVE-2009-20001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-20001/
Summaries are generated and may contain mistakes; the official description above is the record.
