# CVE-2009-2422: rails vulnerable to improper authentication

> Attackers can bypass authentication in Ruby on Rails applications using the vulnerable example digest authentication code by sending an invalid username without a password.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2009
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2009-2422, GHSA-rxq3-gm4p-5fj4

## What is CVE-2009-2422?

CVE-2009-2422 is a critical authentication bypass vulnerability in Apple Mac Os X, published on 10 Jul 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The example code for the digest authentication functionality (http_authentication.rb) in Ruby on Rails before 2.3.3 defines an authenticate_or_request_with_http_digest block that returns nil instead of false when the user does not exist, which allows context-dependent attackers to bypass authentication for applications that are derived from this example by sending an invalid username without a password.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2009-2422?

2 open source packages ship an affected version, including rails. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails` | RubyGems | All versions | 2.3.3 |
| `rails` | RubyGems | All versions | 2.3.3 |

Products: Apple Mac Os X, Apple Mac Os X Server, Rubyonrails Ruby on Rails.

## How do I fix CVE-2009-2422?

Upgrade rails to 2.3.3 or later.

## Is CVE-2009-2422 being exploited?

There is no known exploitation of CVE-2009-2422 in the wild and no public exploit code.

## Other vulnerabilities in Apple Mac Os X

- [CVE-2014-7169](https://insights.sbomify.com/CVE-2014-7169/): GNU Bourne-Again Shell (Bash) Arbitrary Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-6271](https://insights.sbomify.com/CVE-2014-6271/): GNU Bourne-Again Shell (Bash) Arbitrary Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-1823](https://insights.sbomify.com/CVE-2012-1823/): PHP-CGI Query String Parameter (critical 9.8, exploited in the wild)
- [CVE-2021-30713](https://insights.sbomify.com/CVE-2021-30713/): Apple macOS Unspecified (high 7.8, exploited in the wild)
- [CVE-2019-8526](https://insights.sbomify.com/CVE-2019-8526/): Apple macOS Use-After-Free (high 7.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-2422 and fix it if it is affected.

What it is: CVE-2009-2422 is a critical authentication bypass vulnerability in Apple Mac Os X, published on 10 Jul 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-2422 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails (RubyGems): affected all versions; fixed in 2.3.3
- rails (RubyGems): affected all versions; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-2422/ (Markdown: https://insights.sbomify.com/CVE-2009-2422/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-2422
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-2422
- OSV: https://osv.dev/vulnerability/CVE-2009-2422

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-2422/
Summaries are generated and may contain mistakes; the official description above is the record.
