CVE-2009-2693 Apache Tomcat Directory Traversal vulnerability
Remote attackers can overwrite arbitrary files via path traversal in WAR entries, potentially leading to code execution on Apache Tomcat servers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2009-2693?
CVE-2009-2693 is a medium-severity path traversal vulnerability in Apache Tomcat, published on 28 Jan 2010. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Directory traversal vulnerability in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20 allows remote attackers to create or overwrite arbitrary files via a .. (dot dot) in an entry in a WAR file, as demonstrated by a ../../bin/catalina.bat entry.
Weakness: CWE-22
Which versions are affected by CVE-2009-2693?
4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.29 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.29 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.24 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.24 |
Products include Apache Tomcat.
How do I fix CVE-2009-2693?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.29 or 6.0.24.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2009-2693 being exploited?
There is no known exploitation of CVE-2009-2693 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-ggx9-4728-588r.