# CVE-2009-2693: Apache Tomcat Directory Traversal vulnerability

> Remote attackers can overwrite arbitrary files via path traversal in WAR entries, potentially leading to code execution on Apache Tomcat servers.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-ggx9-4728-588r

## What is CVE-2009-2693?

CVE-2009-2693 is a medium-severity path traversal vulnerability in Apache Tomcat, published on 28 Jan 2010. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directory traversal vulnerability in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20 allows remote attackers to create or overwrite arbitrary files via a .. (dot dot) in an entry in a WAR file, as demonstrated by a ../../bin/catalina.bat entry.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2009-2693?

4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.29 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.29 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.24 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.24 |

Products: Apache Tomcat.

## How do I fix CVE-2009-2693?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.29 or 6.0.24.

## Is CVE-2009-2693 being exploited?

There is no known exploitation of CVE-2009-2693 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-2693 and fix it if it is affected.

What it is: CVE-2009-2693 is a medium-severity path traversal vulnerability in Apache Tomcat, published on 28 Jan 2010. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-2693 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.29
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.29
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.24
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-2693/ (Markdown: https://insights.sbomify.com/CVE-2009-2693/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-2693
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-2693
- OSV: https://osv.dev/vulnerability/CVE-2009-2693

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-2693/
Summaries are generated and may contain mistakes; the official description above is the record.
