CVE-2009-2737 Roundup Improper Access Control
Authenticated users with edit privileges can bypass permission checks to modify arbitrary items, including settings and user roles, in the Roundup issue tracker.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2009-2737?
CVE-2009-2737 is a medium-severity missing authorization vulnerability in n/a, published on 11 Aug 2009. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.
Weakness: CWE-264
Which versions are affected by CVE-2009-2737?
5 open source packages ship an affected version, including roundup and Roundup. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
roundup PyPI | From 1.2 | 1.2.1, 1.4.7 |
roundup PyPI | From 1.2 | 1.2.1 |
roundup PyPI | From 1.4 | 1.4.7 |
Roundup PyPI | From 1.2 | 1.2.1 |
Roundup PyPI | From 1.4 | 1.4.7 |
Products include Toni Mueller Roundup.
How do I fix CVE-2009-2737?
Upgrade roundup to a fixed version for your release line: 1.2.1 or 1.4.7.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2009-2737 being exploited?
There is no known exploitation of CVE-2009-2737 in the wild and no public exploit code.
Sources
Also known as DSA-1754-1, GHSA-9rj9-5wcv-xgf2, PYSEC-2026-744.