# CVE-2009-2737: Roundup Improper Access Control

> Authenticated users with edit privileges can bypass permission checks to modify arbitrary items, including settings and user roles, in the Roundup issue tracker.

- **Severity:** Medium 5.5 (`AV:N/AC:L/Au:S/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2009
- **Updated:** 7 Aug 2024
- **Also known as:** DSA-1754-1, GHSA-9rj9-5wcv-xgf2, PYSEC-2026-744

## What is CVE-2009-2737?

CVE-2009-2737 is a medium-severity missing authorization vulnerability in n/a, published on 11 Aug 2009. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.

Weakness: CWE-264

## Which versions are affected by CVE-2009-2737?

5 open source packages ship an affected version, including roundup and Roundup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `roundup` | PyPI | From 1.2 | 1.2.1, 1.4.7 |
| `roundup` | PyPI | From 1.2 | 1.2.1 |
| `roundup` | PyPI | From 1.4 | 1.4.7 |
| `Roundup` | PyPI | From 1.2 | 1.2.1 |
| `Roundup` | PyPI | From 1.4 | 1.4.7 |

Products: Toni Mueller Roundup.

## How do I fix CVE-2009-2737?

Upgrade roundup to a fixed version for your release line: 1.2.1 or 1.4.7.

## Is CVE-2009-2737 being exploited?

There is no known exploitation of CVE-2009-2737 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-2737 and fix it if it is affected.

What it is: CVE-2009-2737 is a medium-severity missing authorization vulnerability in n/a, published on 11 Aug 2009. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-2737 in the wild and no public exploit code.

Affected packages and fixed versions:
- roundup (PyPI): affected from 1.2; fixed in 1.2.1, 1.4.7
- roundup (PyPI): affected from 1.2; fixed in 1.2.1
- roundup (PyPI): affected from 1.4; fixed in 1.4.7
- Roundup (PyPI): affected from 1.2; fixed in 1.2.1
- Roundup (PyPI): affected from 1.4; fixed in 1.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-2737/ (Markdown: https://insights.sbomify.com/CVE-2009-2737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-2737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-2737
- OSV: https://osv.dev/vulnerability/CVE-2009-2737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-2737/
Summaries are generated and may contain mistakes; the official description above is the record.
