CVE-2009-2901 Improper Authentication in Apache Tomcat
Remote attackers can bypass authentication in Apache Tomcat by exploiting residual files from failed undeploys when autoDeploy is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2009-2901?
CVE-2009-2901 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 28 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The autodeployment process in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20, when autoDeploy is enabled, deploys appBase files that remain from a failed undeploy, which might allow remote attackers to bypass intended authentication requirements via HTTP requests.
Weakness: CWE-264
Which versions are affected by CVE-2009-2901?
4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.29 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.29 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.24 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.24 |
Products include Apache Tomcat.
How do I fix CVE-2009-2901?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.29 or 6.0.24.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2009-2901 being exploited?
There is no known exploitation of CVE-2009-2901 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-hjfh-7c4v-7q8h.