# CVE-2009-2901: Improper Authentication in Apache Tomcat

> Remote attackers can bypass authentication in Apache Tomcat by exploiting residual files from failed undeploys when autoDeploy is enabled.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-hjfh-7c4v-7q8h

## What is CVE-2009-2901?

CVE-2009-2901 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 28 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The autodeployment process in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20, when autoDeploy is enabled, deploys appBase files that remain from a failed undeploy, which might allow remote attackers to bypass intended authentication requirements via HTTP requests.

Weakness: CWE-264

## Which versions are affected by CVE-2009-2901?

4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.29 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.29 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.24 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.24 |

Products: Apache Tomcat.

## How do I fix CVE-2009-2901?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.29 or 6.0.24.

## Is CVE-2009-2901 being exploited?

There is no known exploitation of CVE-2009-2901 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-2901 and fix it if it is affected.

What it is: CVE-2009-2901 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 28 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-2901 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.29
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.29
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.24
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-2901/ (Markdown: https://insights.sbomify.com/CVE-2009-2901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-2901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-2901
- OSV: https://osv.dev/vulnerability/CVE-2009-2901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-2901/
Summaries are generated and may contain mistakes; the official description above is the record.
