{"answers":{"affected":"5 open source packages ship an affected version, including pygresql and PyGreSQL. It affects 1 product.","exploited":"There is no known exploitation of CVE-2009-2940 in the wild and no public exploit code.","fix":"Upgrade pygresql to 4.1 or later.","what":"CVE-2009-2940 is a high-severity SQL injection vulnerability in n/a, published on 22 Oct 2009. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2009-2940 and fix it if it is affected.\n\nWhat it is: CVE-2009-2940 is a high-severity SQL injection vulnerability in n/a, published on 22 Oct 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2009-2940 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pygresql (PyPI): affected all versions up to 3.8.1; no fix listed\n- pygresql (PyPI): affected from 3.8.1 up to 4.0; no fix listed\n- pygresql (PyPI): affected from 4.0; fixed in 4.1\n- PyGreSQL (PyPI): affected all versions up to 3.8.1; no fix listed\n- PyGreSQL (PyPI): affected from 4.0; fixed in 4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-2940/ (Markdown: https://insights.sbomify.com/CVE-2009-2940/index.md)","id":"CVE-2009-2940","markdown":"https://insights.sbomify.com/CVE-2009-2940/index.md","name":"CVE-2009-2940","record":{"aliases":["DEBIAN-CVE-2009-2940","DSA-1911-1","GHSA-xv6x-43gq-4hfj","PYSEC-2009-18"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python PostgreSQL library","requires_auth":"none","summary":"Remote attackers can exploit improper string escaping in the pygresql module to perform SQL injection attacks, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pygresql","vendor":"pygresql"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"The pygresql module 3.8.1 and 4.0 for Python does not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PyGreSQL Might Be Vulnerable to Encoding-Based SQL Injection","id":"CVE-2009-2940","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2009"},"n_packages":5,"n_references":5,"next":{"headline":"SQL injection in n/a","id":"CVE-2009-2942"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.8.1"],"package":"PyGreSQL","purl":null,"source":"GHSA-xv6x-43gq-4hfj"},{"ecosystem":"PyPI","fixed":["4.1"],"introduced":["4.0"],"last_affected":[],"package":"PyGreSQL","purl":null,"source":"GHSA-xv6x-43gq-4hfj"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.8.1"],"package":"pygresql","purl":"pkg:pypi/pygresql","source":"GHSA-xv6x-43gq-4hfj"},{"ecosystem":"PyPI","fixed":[],"introduced":["3.8.1"],"last_affected":["4.0"],"package":"pygresql","purl":"pkg:pypi/pygresql","source":"PYSEC-2009-18"},{"ecosystem":"PyPI","fixed":["4.1"],"introduced":["4.0"],"last_affected":[],"package":"pygresql","purl":"pkg:pypi/pygresql","source":"GHSA-xv6x-43gq-4hfj"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2009-2939"},"products":["n/a"],"published":"2009-10-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can exploit improper string escaping in the pygresql module to perform SQL injection attacks, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2009-2940/"}