# CVE-2009-2959: Buildbot Cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML into the Buildbot web status view, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2009
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2009-2959, GHSA-jqqh-999x-w26w, PYSEC-2009-1

## What is CVE-2009-2959?

CVE-2009-2959 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Aug 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the waterfall web status view (status/web/waterfall.py) in Buildbot 0.7.6 through 0.7.11p1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2009-2959?

3 open source packages ship an affected version, including buildbot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `buildbot` | PyPI | From 0.7.6 | 0.7.11p3 |
| `buildbot` | PyPI | From 0.7.6 | 0.7.11p3 |
| `buildbot` | PyPI | From 0.7.6 | 0.7.12 |

Products: Buildbot Buildbot.

## How do I fix CVE-2009-2959?

Upgrade buildbot to a fixed version for your release line: 0.7.11p3 or 0.7.12.

## Is CVE-2009-2959 being exploited?

There is no known exploitation of CVE-2009-2959 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-12300](https://insights.sbomify.com/CVE-2019-12300/): Improper Authentication in Buildbot (critical 9.8)
- [CVE-2019-7313](https://insights.sbomify.com/CVE-2019-7313/): Buildbot CRLF Injection (medium 6.1)
- [CVE-2009-2967](https://insights.sbomify.com/CVE-2009-2967/): Buildbot vulnerable to cross-site scripting (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-2959 and fix it if it is affected.

What it is: CVE-2009-2959 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Aug 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2009-2959 in the wild and no public exploit code.

Affected packages and fixed versions:
- buildbot (PyPI): affected from 0.7.6; fixed in 0.7.11p3
- buildbot (PyPI): affected from 0.7.6; fixed in 0.7.11p3
- buildbot (PyPI): affected from 0.7.6; fixed in 0.7.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-2959/ (Markdown: https://insights.sbomify.com/CVE-2009-2959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-2959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-2959
- OSV: https://osv.dev/vulnerability/CVE-2009-2959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-2959/
Summaries are generated and may contain mistakes; the official description above is the record.
