CVE-2009-2967 Buildbot vulnerable to cross-site scripting
Remote attackers can inject arbitrary web script or HTML into Buildbot, potentially compromising user sessions or data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2009-2967?
CVE-2009-2967 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Aug 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in Buildbot 0.7.6 through 0.7.11p2 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors, different vulnerabilities than CVE-2009-2959.
Weakness: CWE-79
Which versions are affected by CVE-2009-2967?
3 open source packages ship an affected version, including buildbot. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
buildbot PyPI | From 0.7.6 | 0.7.11p3 |
buildbot PyPI | From 0.7.6 | 0.7.11p3 |
buildbot PyPI | From 0.7.6 | 0.7.12 |
Products include Buildbot Buildbot.
How do I fix CVE-2009-2967?
Upgrade buildbot to a fixed version for your release line: 0.7.11p3 or 0.7.12.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2009-2967 being exploited?
There is no known exploitation of CVE-2009-2967 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2009-2967, GHSA-mj3x-wprp-mvj9, PYSEC-2009-2.