# CVE-2009-3086: actionpack and activesupport vulnerable to information leaks

> Remote attackers can exploit a timing side-channel in cookie signature verification to forge valid digests, potentially bypassing authentication or integrity checks.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2009
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2009-3086, GHSA-fg9w-g6m4-557j

## What is CVE-2009-3086?

CVE-2009-3086 is a medium-severity vulnerability in Rubyonrails Rails, published on 8 Sep 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A certain algorithm in Ruby on Rails 2.1.0 through 2.2.2, and 2.3.x before 2.3.4, leaks information about the complexity of message-digest signature verification in the cookie store, which might allow remote attackers to forge a digest via multiple attempts.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2009-3086?

8 open source packages ship an affected version, including actionpack and activesupport. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 2.1.0 | 2.2.3 |
| `actionpack` | RubyGems | From 2.1.0 | 2.2.3 |
| `actionpack` | RubyGems | From 2.3.0 | 2.3.4 |
| `actionpack` | RubyGems | From 2.3.0 | 2.3.4 |
| `activesupport` | RubyGems | From 2.1.0 | 2.2.3 |
| `activesupport` | RubyGems | From 2.1.0 | 2.2.3 |
| `activesupport` | RubyGems | From 2.3.0 | 2.3.4 |
| `activesupport` | RubyGems | From 2.3.0 | 2.3.4 |

Products: Rubyonrails Rails.

## How do I fix CVE-2009-3086?

Upgrade actionpack to a fixed version for your release line: 2.2.3 or 2.3.4.

## Is CVE-2009-3086 being exploited?

There is no known exploitation of CVE-2009-3086 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-3086 and fix it if it is affected.

What it is: CVE-2009-3086 is a medium-severity vulnerability in Rubyonrails Rails, published on 8 Sep 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-3086 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 2.1.0; fixed in 2.2.3
- actionpack (RubyGems): affected from 2.1.0; fixed in 2.2.3
- actionpack (RubyGems): affected from 2.3.0; fixed in 2.3.4
- actionpack (RubyGems): affected from 2.3.0; fixed in 2.3.4
- activesupport (RubyGems): affected from 2.1.0; fixed in 2.2.3
- activesupport (RubyGems): affected from 2.1.0; fixed in 2.2.3
- activesupport (RubyGems): affected from 2.3.0; fixed in 2.3.4
- activesupport (RubyGems): affected from 2.3.0; fixed in 2.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-3086/ (Markdown: https://insights.sbomify.com/CVE-2009-3086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-3086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-3086
- OSV: https://osv.dev/vulnerability/CVE-2009-3086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-3086/
Summaries are generated and may contain mistakes; the official description above is the record.
