{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2009-3617 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2009-3617 is a high-severity vulnerability in n/a, published on 20 Oct 2009. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2009-3617 and fix it if it is affected.\n\nWhat it is: CVE-2009-3617 is a high-severity vulnerability in n/a, published on 20 Oct 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2009-3617 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-3617/ (Markdown: https://insights.sbomify.com/CVE-2009-3617/index.md)","id":"CVE-2009-3617","markdown":"https://insights.sbomify.com/CVE-2009-3617/index.md","name":"CVE-2009-3617","record":{"aliases":["DEBIAN-CVE-2009-3617","GHSA-m6c3-p3rg-chxv","openSUSE-SU-2024:10060-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"aria2 download utility","requires_auth":"none","summary":"Remote attackers can execute arbitrary code or crash aria2 via format string specifiers in a download URI when logging is enabled.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"aria2","vendor":"tatsuhiro_tsujikawa"}],"cvss":{"score":7.6,"severity":"high","source":"nvd","vector":"AV:N/AC:H/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-134","name":"Use of Externally-Controlled Format String"}],"description":"Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI.  NOTE: some of these details are obtained from third party information.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Other in n/a","id":"CVE-2009-3617","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2009"},"n_packages":1,"n_references":9,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2009-3618"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.29.0-1.1"],"introduced":["0"],"last_affected":[],"package":"aria2","purl":"pkg:rpm/opensuse/aria2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10060-1"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2009-3616"},"products":["n/a"],"published":"2009-10-20","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2009-3575","kev_date_added":null,"published":"2009-10-07"},{"cvss_score":4.3,"headline":"Path traversal in n/a","id":"CVE-2010-1512","kev_date_added":null,"published":"2010-05-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code or crash aria2 via format string specifiers in a download URI when logging is enabled.","url":"https://insights.sbomify.com/CVE-2009-3617/"}