CVE-2009-3630 TYPO3 Backend vulnerable to Frame Hijacking
Authenticated users can hijack TYPO3 backend framesets to display arbitrary websites, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2009-3630?
CVE-2009-3630 is a medium-severity vulnerability in Typo3 Typo3, published on 2 Nov 2009. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote authenticated users to place arbitrary web sites in TYPO3 backend framesets via crafted parameters, related to a "frame hijacking" issue.
Which versions are affected by CVE-2009-3630?
8 open source packages ship an affected version, including typo3/cms-backend. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-backend Packagist | All versions to 4.0.13 | None |
typo3/cms-backend Packagist | All versions to 4.0.13 | None |
typo3/cms-backend Packagist | From 4.1.0 | 4.1.13 |
typo3/cms-backend Packagist | From 4.1.0 | 4.1.13 |
typo3/cms-backend Packagist | From 4.2.0 | 4.2.10 |
typo3/cms-backend Packagist | From 4.2.0 | 4.2.10 |
2 more packages
typo3/cms-backend Packagist | From 4.3alpha1 | 4.3beta2 |
typo3/cms-backend Packagist | From 4.3alpha1 | 4.3beta2 |
Products include Typo3 Typo3.
How do I fix CVE-2009-3630?
Upgrade typo3/cms-backend to a fixed version for your release line: 4.1.13, 4.2.10 or 4.3beta2.
Is CVE-2009-3630 being exploited?
There is no known exploitation of CVE-2009-3630 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-mg66-3x8x-r8g2.