# CVE-2009-3631: TYPO3 Backend Command Injection via Shell Metacharacters in Uploaded File Name

> Authenticated attackers can execute arbitrary commands via shell metacharacters in filenames when DAM or FTP upload is enabled.

- **Severity:** High 8.5 (`AV:N/AC:M/Au:S/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-3cqw-pxgr-jhrm

## What is CVE-2009-3631?

CVE-2009-3631 is a high-severity command injection vulnerability in Typo3 Typo3, published on 2 Nov 2009. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2, when the DAM extension or ftp upload is enabled, allows remote authenticated users to execute arbitrary commands via shell metacharacters in a filename.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2009-3631?

8 open source packages ship an affected version, including typo3/cms-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-backend` | Packagist | All versions to 4.0.13 | None |
| `typo3/cms-backend` | Packagist | All versions to 4.0.13 | None |
| `typo3/cms-backend` | Packagist | From 4.1.0 | 4.1.13 |
| `typo3/cms-backend` | Packagist | From 4.1.0 | 4.1.13 |
| `typo3/cms-backend` | Packagist | From 4.2.0 | 4.2.10 |
| `typo3/cms-backend` | Packagist | From 4.2.0 | 4.2.10 |
| `typo3/cms-backend` | Packagist | From 4.3alpha1 | 4.3beta2 |
| `typo3/cms-backend` | Packagist | From 4.3alpha1 | 4.3beta2 |

Products: Typo3 Typo3.

## How do I fix CVE-2009-3631?

Upgrade typo3/cms-backend to a fixed version for your release line: 4.1.13, 4.2.10 or 4.3beta2.

## Is CVE-2009-3631 being exploited?

There is no known exploitation of CVE-2009-3631 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-3631 and fix it if it is affected.

What it is: CVE-2009-3631 is a high-severity command injection vulnerability in Typo3 Typo3, published on 2 Nov 2009. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-3631 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-backend (Packagist): affected all versions up to 4.0.13; no fix listed
- typo3/cms-backend (Packagist): affected all versions up to 4.0.13; no fix listed
- typo3/cms-backend (Packagist): affected from 4.1.0; fixed in 4.1.13
- typo3/cms-backend (Packagist): affected from 4.1.0; fixed in 4.1.13
- typo3/cms-backend (Packagist): affected from 4.2.0; fixed in 4.2.10
- typo3/cms-backend (Packagist): affected from 4.2.0; fixed in 4.2.10
- typo3/cms-backend (Packagist): affected from 4.3alpha1; fixed in 4.3beta2
- typo3/cms-backend (Packagist): affected from 4.3alpha1; fixed in 4.3beta2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-3631/ (Markdown: https://insights.sbomify.com/CVE-2009-3631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-3631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-3631
- OSV: https://osv.dev/vulnerability/CVE-2009-3631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-3631/
Summaries are generated and may contain mistakes; the official description above is the record.
