# CVE-2009-3633: TYPO3 API function vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML via the t3lib_div::quoteJSvalue function in TYPO3, potentially compromising user sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Nov 2009
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-m7rg-85g8-28m9

## What is CVE-2009-3633?

CVE-2009-3633 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 2 Nov 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the t3lib_div::quoteJSvalue API function in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to the sanitizing algorithm.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2009-3633?

8 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | All versions to 4.0.13 | None |
| `typo3/cms-core` | Packagist | All versions to 4.0.13 | None |
| `typo3/cms-core` | Packagist | From 4.1.0 | 4.1.13 |
| `typo3/cms-core` | Packagist | From 4.1.0 | 4.1.13 |
| `typo3/cms-core` | Packagist | From 4.2.0 | 4.2.10 |
| `typo3/cms-core` | Packagist | From 4.2.0 | 4.2.10 |
| `typo3/cms-core` | Packagist | From 4.3alpha1 | 4.3beta2 |
| `typo3/cms-core` | Packagist | From 4.3alpha1 | 4.3beta2 |

Products: Typo3 Typo3.

## How do I fix CVE-2009-3633?

Upgrade typo3/cms-core to a fixed version for your release line: 4.1.13, 4.2.10 or 4.3beta2.

## Is CVE-2009-3633 being exploited?

There is no known exploitation of CVE-2009-3633 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-3633 and fix it if it is affected.

What it is: CVE-2009-3633 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 2 Nov 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2009-3633 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected all versions up to 4.0.13; no fix listed
- typo3/cms-core (Packagist): affected all versions up to 4.0.13; no fix listed
- typo3/cms-core (Packagist): affected from 4.1.0; fixed in 4.1.13
- typo3/cms-core (Packagist): affected from 4.1.0; fixed in 4.1.13
- typo3/cms-core (Packagist): affected from 4.2.0; fixed in 4.2.10
- typo3/cms-core (Packagist): affected from 4.2.0; fixed in 4.2.10
- typo3/cms-core (Packagist): affected from 4.3alpha1; fixed in 4.3beta2
- typo3/cms-core (Packagist): affected from 4.3alpha1; fixed in 4.3beta2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-3633/ (Markdown: https://insights.sbomify.com/CVE-2009-3633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-3633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-3633
- OSV: https://osv.dev/vulnerability/CVE-2009-3633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-3633/
Summaries are generated and may contain mistakes; the official description above is the record.
