CVE-2009-3636 Typo3 API Install Tool vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML into the TYPO3 Install Tool, potentially compromising administrator sessions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2009-3636?
CVE-2009-3636 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 2 Nov 2009. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.
Weakness: CWE-79
Which versions are affected by CVE-2009-3636?
8 open source packages ship an affected version, including typo3/cms-install. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-install Packagist | All versions to 4.0.13 | None |
typo3/cms-install Packagist | All versions to 4.0.13 | None |
typo3/cms-install Packagist | From 4.1.0 | 4.1.13 |
typo3/cms-install Packagist | From 4.1.0 | 4.1.13 |
typo3/cms-install Packagist | From 4.2.0 | 4.2.10 |
typo3/cms-install Packagist | From 4.2.0 | 4.2.10 |
2 more packages
typo3/cms-install Packagist | From 4.3alpha1 | 4.3beta2 |
typo3/cms-install Packagist | From 4.3alpha1 | 4.3beta2 |
Products include Typo3 Typo3.
How do I fix CVE-2009-3636?
Upgrade typo3/cms-install to a fixed version for your release line: 4.1.13, 4.2.10 or 4.3beta2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2009-3636 being exploited?
There is no known exploitation of CVE-2009-3636 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-c73w-4rcj-2622.