CVE-2009-3696 phpMyAdmin Cross-site Scripting In MySQL Table Name
Remote attackers can inject arbitrary web script or HTML via a crafted MySQL table name in phpMyAdmin, requiring user interaction to execute.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2009-3696?
CVE-2009-3696 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 16 Oct 2009. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.11.x before 2.11.9.6 and 3.x before 3.2.2.1 allows remote attackers to inject arbitrary web script or HTML via a crafted name for a MySQL table.
Weakness: CWE-79
Which versions are affected by CVE-2009-3696?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 2.11.0 | 2.11.9.6 |
phpmyadmin/phpmyadmin Packagist | From 2.11.0 | 2.11.9.6 |
phpmyadmin/phpmyadmin Packagist | From 3.0.0 | 3.2.2.1 |
phpmyadmin/phpmyadmin Packagist | From 3.0.0 | 3.2.2.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2009-3696?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 2.11.9.6 or 3.2.2.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2009-3696 being exploited?
There is no known exploitation of CVE-2009-3696 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2009-3696, GHSA-5pvv-f8h3-gw96.