# CVE-2009-3724: Cross-site scripting in markdown2 for python

> Attackers can inject malicious scripts via markdown input, potentially executing code in the context of users viewing the rendered content.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jan 2020
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-72cx-5ff9-4hhc, PYSEC-2020-235, SNYK-PYTHON-PYRAD-40000

## What is CVE-2009-3724?

CVE-2009-3724 is a medium-severity cross-site scripting vulnerability in python-markdown2, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

python-markdown2 before 1.0.1.14 has multiple cross-site scripting (XSS) issues.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2009-3724?

3 open source packages ship an affected version, including markdown2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown2` | PyPI | All versions | 1.0.1.14 |
| `markdown2` | PyPI | All versions | 1.0.1.14 |
| `markdown2` | PyPI | All versions | 1.0.1.14 |

Products: Python-Markdown2 Project Python-Markdown2.

## How do I fix CVE-2009-3724?

Upgrade markdown2 to 1.0.1.14 or later.

## Is CVE-2009-3724 being exploited?

There is no known exploitation of CVE-2009-3724 in the wild and no public exploit code.

## Other vulnerabilities in python-markdown2

- [CVE-2020-11888](https://insights.sbomify.com/CVE-2020-11888/): XSS in python-markdown2 (medium 6.1)
- [CVE-2018-5773](https://insights.sbomify.com/CVE-2018-5773/): markdown2 is vulnerable to cross-site scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-3724 and fix it if it is affected.

What it is: CVE-2009-3724 is a medium-severity cross-site scripting vulnerability in python-markdown2, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2009-3724 in the wild and no public exploit code.

Affected packages and fixed versions:
- markdown2 (PyPI): affected all versions; fixed in 1.0.1.14
- markdown2 (PyPI): affected all versions; fixed in 1.0.1.14
- markdown2 (PyPI): affected all versions; fixed in 1.0.1.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-3724/ (Markdown: https://insights.sbomify.com/CVE-2009-3724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-3724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-3724
- OSV: https://osv.dev/vulnerability/CVE-2009-3724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-3724/
Summaries are generated and may contain mistakes; the official description above is the record.
