# CVE-2009-3818: freeCap CAPTCHA extension for TYPO3 has vulnerability in the session handling feature

> Unspecified vulnerability in freeCap CAPTCHA extension for TYPO3 allows attackers to exploit session handling flaws with unknown impact.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 28 Oct 2009
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-m8c5-5g3h-jjfg

## What is CVE-2009-3818?

CVE-2009-3818 is a critical vulnerability in n/a, published on 28 Oct 2009. It can be exploited over the network.

### Official description

Unspecified vulnerability in the session handling feature in freeCap CAPTCHA (sr_freecap) extension 1.2.0 and earlier for TYPO3 has unknown impact and attack vectors.

## Which versions are affected by CVE-2009-3818?

2 open source packages ship an affected version, including sjbr/sr-freecap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sjbr/sr-freecap` | Packagist | All versions | 1.2.2 |
| `sjbr/sr-freecap` | Packagist | All versions | 1.2.2 |

Products: Stanislas Rolland Sr Freecap.

## How do I fix CVE-2009-3818?

Upgrade sjbr/sr-freecap to 1.2.2 or later.

## Is CVE-2009-3818 being exploited?

There is no known exploitation of CVE-2009-3818 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-3818 and fix it if it is affected.

What it is: CVE-2009-3818 is a critical vulnerability in n/a, published on 28 Oct 2009. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2009-3818 in the wild and no public exploit code.

Affected packages and fixed versions:
- sjbr/sr-freecap (Packagist): affected all versions; fixed in 1.2.2
- sjbr/sr-freecap (Packagist): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-3818/ (Markdown: https://insights.sbomify.com/CVE-2009-3818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-3818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-3818
- OSV: https://osv.dev/vulnerability/CVE-2009-3818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-3818/
Summaries are generated and may contain mistakes; the official description above is the record.
