{"answers":{"affected":"2 open source packages ship an affected version, including jruby-openssl. It affects 1 product.","exploited":"There is no known exploitation of CVE-2009-4123 in the wild and no public exploit code.","fix":"Upgrade jruby-openssl to 0.6 or later.","what":"CVE-2009-4123 is a high-severity vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2009-4123 and fix it if it is affected.\n\nWhat it is: CVE-2009-4123 is a high-severity vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2009-4123 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jruby-openssl (RubyGems): affected all versions; fixed in 0.6\n- jruby-openssl (RubyGems): affected all versions; fixed in 0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-4123/ (Markdown: https://insights.sbomify.com/CVE-2009-4123/index.md)","id":"CVE-2009-4123","markdown":"https://insights.sbomify.com/CVE-2009-4123/index.md","name":"CVE-2009-4123","record":{"aliases":["GHSA-xgv7-pqqh-h2w9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JRuby SSL library","requires_auth":"none","summary":"Attackers can bypass SSL certificate validation in JRuby applications, enabling man-in-the-middle attacks against encrypted connections.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jruby-openssl","vendor":"jruby"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"The jruby-openssl gem before 0.6 for JRuby mishandles SSL certificate validation.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"jruby-openssl gem for JRuby fails to do proper certificate validation","id":"CVE-2009-4123","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2009"},"n_packages":2,"n_references":4,"next":{"headline":"Memory corruption in n/a","id":"CVE-2009-4124"},"packages":[{"ecosystem":"RubyGems","fixed":["0.6"],"introduced":["0"],"last_affected":[],"package":"jruby-openssl","purl":null,"source":"GHSA-xgv7-pqqh-h2w9"},{"ecosystem":"RubyGems","fixed":["0.6"],"introduced":["0"],"last_affected":[],"package":"jruby-openssl","purl":"pkg:gem/jruby-openssl","source":"GHSA-xgv7-pqqh-h2w9"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2009-4121"},"products":["n/a"],"published":"2023-12-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Attackers can bypass SSL certificate validation in JRuby applications, enabling man-in-the-middle attacks against encrypted connections.","url":"https://insights.sbomify.com/CVE-2009-4123/"}