# CVE-2009-4160: TYPO3 Simple Download-System with Counter and Categories Vulnerable to Information Disclosure

> Remote attackers can obtain sensitive information from the TYPO3 kk_downloader extension via unspecified vectors.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2009
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p65f-652v-35r2

## What is CVE-2009-4160?

CVE-2009-4160 is a medium-severity vulnerability in n/a, published on 2 Dec 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unspecified vulnerability in the Simple download-system with counter and categories (kk_downloader) extension 1.2.1 and earlier for TYPO3 allows remote attackers to obtain sensitive information via unknown attack vectors.

## Which versions are affected by CVE-2009-4160?

2 open source packages ship an affected version, including jweiland/kk-downloader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jweiland/kk-downloader` | Packagist | All versions | 1.2.2 |
| `jweiland/kk-downloader` | Packagist | All versions | 1.2.2 |

Products: Kurt Kunig Kk Downloader.

## How do I fix CVE-2009-4160?

Upgrade jweiland/kk-downloader to 1.2.2 or later.

## Is CVE-2009-4160 being exploited?

There is no known exploitation of CVE-2009-4160 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-4160 and fix it if it is affected.

What it is: CVE-2009-4160 is a medium-severity vulnerability in n/a, published on 2 Dec 2009. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-4160 in the wild and no public exploit code.

Affected packages and fixed versions:
- jweiland/kk-downloader (Packagist): affected all versions; fixed in 1.2.2
- jweiland/kk-downloader (Packagist): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-4160/ (Markdown: https://insights.sbomify.com/CVE-2009-4160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-4160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-4160
- OSV: https://osv.dev/vulnerability/CVE-2009-4160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-4160/
Summaries are generated and may contain mistakes; the official description above is the record.
