{"answers":{"affected":"4 open source packages ship an affected version, including rails. It affects 2 products.","exploited":"There is no known exploitation of CVE-2009-4214 in the wild and no public exploit code.","fix":"Upgrade rails to a fixed version for your release line: 2.2.2 or 2.3.5.","what":"CVE-2009-4214 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 7 Dec 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2009-4214 and fix it if it is affected.\n\nWhat it is: CVE-2009-4214 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 7 Dec 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2009-4214 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails (RubyGems): affected all versions; fixed in 2.2.2\n- rails (RubyGems): affected all versions; fixed in 2.2.2\n- rails (RubyGems): affected from 2.3.0; fixed in 2.3.5\n- rails (RubyGems): affected from 2.3.0; fixed in 2.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-4214/ (Markdown: https://insights.sbomify.com/CVE-2009-4214/index.md)","id":"CVE-2009-4214","markdown":"https://insights.sbomify.com/CVE-2009-4214/index.md","name":"CVE-2009-4214","record":{"aliases":["CVE-2009-4132","DEBIAN-CVE-2009-4214","GHSA-9p3v-wf2w-v29c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via non-printing ASCII characters in the strip_tags function, affecting Ruby on Rails applications.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rails","vendor":"rubyonrails"},{"product":"ruby_on_rails","vendor":"rubyonrails"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects rails","id":"CVE-2009-4214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"rubyonrails:rails","products":["rubyonrails:rails"],"type":"xss","year":"2009"},"n_packages":4,"n_references":15,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2009-4215"},"packages":[{"ecosystem":"RubyGems","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"rails","purl":null,"source":"GHSA-9p3v-wf2w-v29c"},{"ecosystem":"RubyGems","fixed":["2.2.2"],"introduced":["0"],"last_affected":[],"package":"rails","purl":"pkg:gem/rails","source":"GHSA-9p3v-wf2w-v29c"},{"ecosystem":"RubyGems","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"rails","purl":null,"source":"GHSA-9p3v-wf2w-v29c"},{"ecosystem":"RubyGems","fixed":["2.3.5"],"introduced":["2.3.0"],"last_affected":[],"package":"rails","purl":"pkg:gem/rails","source":"GHSA-9p3v-wf2w-v29c"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2009-4212"},"products":["n/a"],"published":"2009-12-07","related":[{"cvss_score":10,"headline":"Active Record contains deserialization of arbitrary YAML","id":"CVE-2013-0277","kev_date_added":null,"published":"2013-02-13"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17916","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17917","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8,"headline":"Rails Active Storage has possible Path Traversal in DiskService","id":"CVE-2026-33195","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch","id":"CVE-2024-26142","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"ReDoS based DoS vulnerability in Action Dispatch","id":"CVE-2023-22792","kev_date_added":null,"published":"2023-02-09"},{"cvss_score":7.5,"headline":"Denial of Service in Action Dispatch","id":"CVE-2021-22902","kev_date_added":null,"published":"2021-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via non-printing ASCII characters in the strip_tags function, affecting Ruby on Rails applications.","url":"https://insights.sbomify.com/CVE-2009-4214/"}