# CVE-2009-4214: Moderate severity vulnerability that affects rails

> Remote attackers can inject arbitrary web script or HTML via non-printing ASCII characters in the strip_tags function, affecting Ruby on Rails applications.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Dec 2009
- **Updated:** 7 Aug 2024
- **Also known as:** CVE-2009-4132, DEBIAN-CVE-2009-4214, GHSA-9p3v-wf2w-v29c

## What is CVE-2009-4214?

CVE-2009-4214 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 7 Dec 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2009-4214?

4 open source packages ship an affected version, including rails. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails` | RubyGems | All versions | 2.2.2 |
| `rails` | RubyGems | All versions | 2.2.2 |
| `rails` | RubyGems | From 2.3.0 | 2.3.5 |
| `rails` | RubyGems | From 2.3.0 | 2.3.5 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2009-4214?

Upgrade rails to a fixed version for your release line: 2.2.2 or 2.3.5.

## Is CVE-2009-4214 being exploited?

There is no known exploitation of CVE-2009-4214 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-4214 and fix it if it is affected.

What it is: CVE-2009-4214 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 7 Dec 2009. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2009-4214 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails (RubyGems): affected all versions; fixed in 2.2.2
- rails (RubyGems): affected all versions; fixed in 2.2.2
- rails (RubyGems): affected from 2.3.0; fixed in 2.3.5
- rails (RubyGems): affected from 2.3.0; fixed in 2.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-4214/ (Markdown: https://insights.sbomify.com/CVE-2009-4214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-4214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-4214
- OSV: https://osv.dev/vulnerability/CVE-2009-4214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-4214/
Summaries are generated and may contain mistakes; the official description above is the record.
