# CVE-2009-4269: Use of Password Hash With Insufficient Computational Effort in Apache Derby

> Weak password hashing in Apache Derby allows attackers to crack passwords via hash collisions, potentially leading to unauthorized data access or account takeover.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-fh32-35w2-rxcc, UBUNTU-CVE-2009-4269

## What is CVE-2009-4269?

CVE-2009-4269 is a low-severity vulnerability in n/a, published on 16 Aug 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The password hash generation algorithm in the BUILTIN authentication functionality for Apache Derby before 10.6.1.0 performs a transformation that reduces the size of the set of inputs to SHA-1, which produces a small search space that makes it easier for local and possibly remote attackers to crack passwords by generating hash collisions, related to password substitution.

Weakness: CWE-310

## Which versions are affected by CVE-2009-4269?

2 open source packages ship an affected version, including org.apache.derby:derby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.derby:derby` | Maven | All versions | 10.6.1.0 |
| `org.apache.derby:derby` | Maven | All versions | 10.6.1.0 |

Products: Apache Derby.

## How do I fix CVE-2009-4269?

Upgrade org.apache.derby:derby to 10.6.1.0 or later.

## Is CVE-2009-4269 being exploited?

There is no known exploitation of CVE-2009-4269 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-46337](https://insights.sbomify.com/CVE-2022-46337/): Apache Derby: LDAP injection vulnerability in authenticator (critical 9.8)
- [CVE-2015-1832](https://insights.sbomify.com/CVE-2015-1832/): Improper Restriction of XML External Entity Reference in Apace Derby (critical 9.1)
- [CVE-2010-2232](https://insights.sbomify.com/CVE-2010-2232/): Improper Access Control in Apache Derby (high 7.5)
- [CVE-2018-1313](https://insights.sbomify.com/CVE-2018-1313/): Improper Access Control in Apache Derby (medium 5.3)
- [CVE-2005-4849](https://insights.sbomify.com/CVE-2005-4849/): Apache Derby exposes user and password attributes (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-4269 and fix it if it is affected.

What it is: CVE-2009-4269 is a low-severity vulnerability in n/a, published on 16 Aug 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-4269 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.derby:derby (Maven): affected all versions; fixed in 10.6.1.0
- org.apache.derby:derby (Maven): affected all versions; fixed in 10.6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-4269/ (Markdown: https://insights.sbomify.com/CVE-2009-4269/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-4269
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-4269
- OSV: https://osv.dev/vulnerability/CVE-2009-4269

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-4269/
Summaries are generated and may contain mistakes; the official description above is the record.
