# CVE-2009-4405: Trac is vulnerable to improper policy checks and missing 'raw' role check in docutils

> Trac fails to enforce policy checks on report results and missing role checks, potentially allowing unauthorized data access.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 23 Dec 2009
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2009-4405, GHSA-f9qv-j5g6-g5cr, PYSEC-2009-7

## What is CVE-2009-4405?

CVE-2009-4405 is a high-severity missing authorization vulnerability in n/a, published on 23 Dec 2009. It can be exploited over the network.

### Official description

Multiple unspecified vulnerabilities in Trac before 0.11.6 have unknown impact and attack vectors, possibly related to (1) "policy checks in report results when using alternate formats" or (2) a "check for the 'raw' role that is missing in docutils < 0.6."

## Which versions are affected by CVE-2009-4405?

3 open source packages ship an affected version, including trac. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trac` | PyPI | All versions | 0.11.6 |
| `trac` | PyPI | All versions | 0.11.6 |
| `trac` | PyPI | All versions | 0.11.6 |

Products: Edgewall Trac.

## How do I fix CVE-2009-4405?

Upgrade trac to 0.11.6 or later.

## Is CVE-2009-4405 being exploited?

There is no known exploitation of CVE-2009-4405 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-2951](https://insights.sbomify.com/CVE-2008-2951/): Trac Open Redirect vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-4405 and fix it if it is affected.

What it is: CVE-2009-4405 is a high-severity missing authorization vulnerability in n/a, published on 23 Dec 2009. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2009-4405 in the wild and no public exploit code.

Affected packages and fixed versions:
- trac (PyPI): affected all versions; fixed in 0.11.6
- trac (PyPI): affected all versions; fixed in 0.11.6
- trac (PyPI): affected all versions; fixed in 0.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-4405/ (Markdown: https://insights.sbomify.com/CVE-2009-4405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-4405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-4405
- OSV: https://osv.dev/vulnerability/CVE-2009-4405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-4405/
Summaries are generated and may contain mistakes; the official description above is the record.
