{"answers":{"affected":"2 open source packages ship an affected version, including webrick. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-4492 exists.","fix":"Upgrade webrick to 1.4.0 or later.","what":"CVE-2009-4492 is a high-severity command injection vulnerability in n/a, published on 13 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2009-4492 and fix it if it is affected.\n\nWhat it is: CVE-2009-4492 is a high-severity command injection vulnerability in n/a, published on 13 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-4492 exists.\n\nAffected packages and fixed versions:\n- webrick (RubyGems): affected all versions; fixed in 1.4.0\n- webrick (RubyGems): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-4492/ (Markdown: https://insights.sbomify.com/CVE-2009-4492/index.md)","id":"CVE-2009-4492","markdown":"https://insights.sbomify.com/CVE-2009-4492/index.md","name":"CVE-2009-4492","record":{"aliases":["GHSA-6mq2-37j5-w6r6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby WEBrick library","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands or modify files via terminal escape sequences in HTTP requests to WEBrick.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"webrick","vendor":"ruby-lang"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.","ecosystems":["RubyGems"],"exploits":{"exploitdb":1,"first_seen":"2010-01-11","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2010-01-11","kind":"exploitdb","ref":"33489","stars":null,"title":"Ruby 1.9.1 - WEBrick 'Terminal Escape Sequence in Logs' Command Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"WEBrick Improper Input Validation vulnerability","id":"CVE-2009-4492","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2009"},"n_packages":2,"n_references":9,"next":{"headline":"Command injection in n/a","id":"CVE-2009-4493"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"webrick","purl":null,"source":"GHSA-6mq2-37j5-w6r6"},{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"webrick","purl":"pkg:gem/webrick","source":"GHSA-6mq2-37j5-w6r6"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2009-4491"},"products":["n/a"],"published":"2010-01-13","related":[{"cvss_score":6.5,"headline":"Ruby WEBrick read_header HTTP Request Smuggling Vulnerability","id":"CVE-2025-6442","kev_date_added":null,"published":"2025-06-25"},{"cvss_score":5.5,"headline":"Path traversal in n/a","id":"CVE-2019-11879","kev_date_added":null,"published":"2019-05-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands or modify files via terminal escape sequences in HTTP requests to WEBrick.","url":"https://insights.sbomify.com/CVE-2009-4492/"}