# CVE-2009-4492: WEBrick Improper Input Validation vulnerability

> Remote attackers can execute arbitrary commands or modify files via terminal escape sequences in HTTP requests to WEBrick.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-6mq2-37j5-w6r6

## What is CVE-2009-4492?

CVE-2009-4492 is a high-severity command injection vulnerability in n/a, published on 13 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

## Which versions are affected by CVE-2009-4492?

2 open source packages ship an affected version, including webrick. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webrick` | RubyGems | All versions | 1.4.0 |
| `webrick` | RubyGems | All versions | 1.4.0 |

Products: Ruby-Lang Webrick.

## How do I fix CVE-2009-4492?

Upgrade webrick to 1.4.0 or later.

## Is CVE-2009-4492 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-4492 exists.

Public exploit code:

- Ruby 1.9.1 - WEBrick 'Terminal Escape Sequence in Logs' Command Injection (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2025-6442](https://insights.sbomify.com/CVE-2025-6442/): Ruby WEBrick read_header HTTP Request Smuggling Vulnerability (medium 6.5)
- [CVE-2019-11879](https://insights.sbomify.com/CVE-2019-11879/): Path traversal in n/a (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-4492 and fix it if it is affected.

What it is: CVE-2009-4492 is a high-severity command injection vulnerability in n/a, published on 13 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2009-4492 exists.

Affected packages and fixed versions:
- webrick (RubyGems): affected all versions; fixed in 1.4.0
- webrick (RubyGems): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-4492/ (Markdown: https://insights.sbomify.com/CVE-2009-4492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-4492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-4492
- OSV: https://osv.dev/vulnerability/CVE-2009-4492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-4492/
Summaries are generated and may contain mistakes; the official description above is the record.
