CVE-2009-4611 Improper input validation in Mort Bay Jetty
Remote attackers can execute arbitrary commands or modify files via unsanitized terminal escape sequences in HTTP requests to Jetty.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2009-4611?
CVE-2009-4611 is a high-severity vulnerability in n/a, published on 13 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mort Bay Jetty 6.x through 6.1.22 and 7.0.0 writes backtrace data without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator, related to (1) a string value in the Age parameter to the default URI for the Cookie Dump Servlet in test-jetty-webapp/src/main/java/com/acme/CookieDump.java under cookie/, (2) an alphabetic value in the A parameter to jsp/expr.jsp, or (3) an alphabetic value in the Content-Length HTTP header to an arbitrary application.
Weakness: CWE-20
Which versions are affected by CVE-2009-4611?
4 open source packages ship an affected version, including org.mortbay.jetty:jetty. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.mortbay.jetty:jetty Maven | From 6.0.0 | 6.1.23 |
org.mortbay.jetty:jetty Maven | From 6.0.0 | 6.1.23 |
org.mortbay.jetty:jetty Maven | From 7.0.0 | 7.0.2 |
org.mortbay.jetty:jetty Maven | From 7.0.0 | 7.0.2 |
Products include Mortbay Jetty.
How do I fix CVE-2009-4611?
Upgrade org.mortbay.jetty:jetty to a fixed version for your release line: 6.1.23 or 7.0.2.
Is CVE-2009-4611 being exploited?
There is no known exploitation of CVE-2009-4611 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as CVE-2009-5047, GHSA-6jxp-7g74-2rc3.