# CVE-2009-4611: Improper input validation in Mort Bay Jetty

> Remote attackers can execute arbitrary commands or modify files via unsanitized terminal escape sequences in HTTP requests to Jetty.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2010
- **Updated:** 7 Aug 2024
- **Also known as:** CVE-2009-5047, GHSA-6jxp-7g74-2rc3

## What is CVE-2009-4611?

CVE-2009-4611 is a high-severity vulnerability in n/a, published on 13 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mort Bay Jetty 6.x through 6.1.22 and 7.0.0 writes backtrace data without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator, related to (1) a string value in the Age parameter to the default URI for the Cookie Dump Servlet in test-jetty-webapp/src/main/java/com/acme/CookieDump.java under cookie/, (2) an alphabetic value in the A parameter to jsp/expr.jsp, or (3) an alphabetic value in the Content-Length HTTP header to an arbitrary application.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2009-4611?

4 open source packages ship an affected version, including org.mortbay.jetty:jetty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.mortbay.jetty:jetty` | Maven | From 6.0.0 | 6.1.23 |
| `org.mortbay.jetty:jetty` | Maven | From 6.0.0 | 6.1.23 |
| `org.mortbay.jetty:jetty` | Maven | From 7.0.0 | 7.0.2 |
| `org.mortbay.jetty:jetty` | Maven | From 7.0.0 | 7.0.2 |

Products: Mortbay Jetty.

## How do I fix CVE-2009-4611?

Upgrade org.mortbay.jetty:jetty to a fixed version for your release line: 6.1.23 or 7.0.2.

## Is CVE-2009-4611 being exploited?

There is no known exploitation of CVE-2009-4611 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2009-5048](https://insights.sbomify.com/CVE-2009-5048/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2011-4461](https://insights.sbomify.com/CVE-2011-4461/): Improper Input Validation in Jetty (medium 5.3)
- [CVE-2009-4609](https://insights.sbomify.com/CVE-2009-4609/): Information disclosure in n/a (medium 5.0)
- [CVE-2009-1523](https://insights.sbomify.com/CVE-2009-1523/): Directory traversal in Mort Bay Jetty (medium 5.0)
- [CVE-2005-3747](https://insights.sbomify.com/CVE-2005-3747/): Mortbay Jetty Discloses JSP Source Code (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-4611 and fix it if it is affected.

What it is: CVE-2009-4611 is a high-severity vulnerability in n/a, published on 13 Jan 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-4611 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.mortbay.jetty:jetty (Maven): affected from 6.0.0; fixed in 6.1.23
- org.mortbay.jetty:jetty (Maven): affected from 6.0.0; fixed in 6.1.23
- org.mortbay.jetty:jetty (Maven): affected from 7.0.0; fixed in 7.0.2
- org.mortbay.jetty:jetty (Maven): affected from 7.0.0; fixed in 7.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-4611/ (Markdown: https://insights.sbomify.com/CVE-2009-4611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-4611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-4611
- OSV: https://osv.dev/vulnerability/CVE-2009-4611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-4611/
Summaries are generated and may contain mistakes; the official description above is the record.
