# CVE-2009-5012: Improper Access Control in pyftpdlib

> Authenticated users can bypass access restrictions to list the root directory in pyftpdlib due to missing permission checks for the MLST command.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2010
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2009-5012, GHSA-h4g7-8m7r-87r9, PYSEC-2010-9

## What is CVE-2009-5012?

CVE-2009-5012 is a medium-severity missing authorization vulnerability in n/a, published on 19 Oct 2010. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ftpserver.py in pyftpdlib before 0.5.2 does not require the l permission for the MLST command, which allows remote authenticated users to bypass intended access restrictions and list the root directory via an FTP session.

Weakness: CWE-264

## Which versions are affected by CVE-2009-5012?

3 open source packages ship an affected version, including pyftpdlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyftpdlib` | PyPI | All versions | 0.5.2 |
| `pyftpdlib` | PyPI | All versions | 0.5.2 |
| `pyftpdlib` | PyPI | All versions | 0.5.2 |

Products: G.rodola Pyftpdlib.

## How do I fix CVE-2009-5012?

Upgrade pyftpdlib to 0.5.2 or later.

## Is CVE-2009-5012 being exploited?

There is no known exploitation of CVE-2009-5012 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-6737](https://insights.sbomify.com/CVE-2007-6737/): Improper Authentication in pyftpdlib (high 7.5)
- [CVE-2008-7263](https://insights.sbomify.com/CVE-2008-7263/): Improper Authentication in pyftpdlib (high 7.5)
- [CVE-2007-6736](https://insights.sbomify.com/CVE-2007-6736/): Directory Traversal in pyftpdlib (medium 6.5)
- [CVE-2007-6741](https://insights.sbomify.com/CVE-2007-6741/): Improper privilege management in pyftpdlib (medium 6.5)
- [CVE-2008-7262](https://insights.sbomify.com/CVE-2008-7262/): Directory traversal in pyftpdlib (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-5012 and fix it if it is affected.

What it is: CVE-2009-5012 is a medium-severity missing authorization vulnerability in n/a, published on 19 Oct 2010. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-5012 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.2
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.2
- pyftpdlib (PyPI): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-5012/ (Markdown: https://insights.sbomify.com/CVE-2009-5012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-5012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-5012
- OSV: https://osv.dev/vulnerability/CVE-2009-5012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-5012/
Summaries are generated and may contain mistakes; the official description above is the record.
