# CVE-2009-5054: Smarty Does Not Consider Umask Values When Setting Permissions

> Smarty library fails to respect umask settings, allowing attackers to bypass intended file access restrictions via standard filesystem operations.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2011
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2009-5054, GHSA-6m9f-8vwq-97pm

## What is CVE-2009-5054?

CVE-2009-5054 is a high-severity vulnerability in n/a, published on 3 Feb 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Smarty before 3.0.0 beta 4 does not consider the umask value when setting the permissions of files, which might allow attackers to bypass intended access restrictions via standard filesystem operations.

Weakness: CWE-264

## Which versions are affected by CVE-2009-5054?

2 open source packages ship an affected version, including smarty/smarty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smarty/smarty` | Packagist | All versions | 3.0.0-beta4 |
| `smarty/smarty` | Packagist | All versions | 3.0.0-beta4 |

Products: Smarty Smarty.

## How do I fix CVE-2009-5054?

Upgrade smarty/smarty to 3.0.0-beta4 or later.

## Is CVE-2009-5054 being exploited?

There is no known exploitation of CVE-2009-5054 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2009-5052](https://insights.sbomify.com/CVE-2009-5052/): Other in n/a (critical 10.0)
- [CVE-2010-4722](https://insights.sbomify.com/CVE-2010-4722/): Other in n/a (critical 10.0)
- [CVE-2010-4724](https://insights.sbomify.com/CVE-2010-4724/): Other in n/a (critical 10.0)
- [CVE-2010-4725](https://insights.sbomify.com/CVE-2010-4725/): Code injection in n/a (critical 10.0)
- [CVE-2010-4726](https://insights.sbomify.com/CVE-2010-4726/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-5054 and fix it if it is affected.

What it is: CVE-2009-5054 is a high-severity vulnerability in n/a, published on 3 Feb 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2009-5054 in the wild and no public exploit code.

Affected packages and fixed versions:
- smarty/smarty (Packagist): affected all versions; fixed in 3.0.0-beta4
- smarty/smarty (Packagist): affected all versions; fixed in 3.0.0-beta4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-5054/ (Markdown: https://insights.sbomify.com/CVE-2009-5054/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-5054
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-5054
- OSV: https://osv.dev/vulnerability/CVE-2009-5054

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-5054/
Summaries are generated and may contain mistakes; the official description above is the record.
