{"answers":{"affected":"3 open source packages ship an affected version, including zope2 and Zope2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2009-5145 in the wild and no public exploit code.","fix":"Upgrade zope2 to 2.12.5 or later.","what":"CVE-2009-5145 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2009-5145 and fix it if it is affected.\n\nWhat it is: CVE-2009-5145 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2009-5145 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zope2 (PyPI): affected all versions; fixed in 2.12.5\n- zope2 (PyPI): affected all versions; fixed in 2.12.5\n- Zope2 (PyPI): affected all versions; fixed in 2.12.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2009-5145/ (Markdown: https://insights.sbomify.com/CVE-2009-5145/index.md)","id":"CVE-2009-5145","markdown":"https://insights.sbomify.com/CVE-2009-5145/index.md","name":"CVE-2009-5145","record":{"aliases":["GHSA-5r4x-qc7q-vj27","PYSEC-2026-763"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Zope web application server","requires_auth":"none","summary":"Cross-site scripting in Zope ZMI pages allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"zope","vendor":"zope"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in ZMI pages that use the manage_tabs_message in Zope 2.11.4, 2.11.2, 2.10.9, 2.10.7, 2.10.6, 2.10.5, 2.10.4, 2.10.2, 2.10.1, 2.12.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zope Cross-site scripting (XSS) vulnerability in ZMI pages","id":"CVE-2009-5145","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2009"},"n_packages":3,"n_references":6,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2009-5146"},"packages":[{"ecosystem":"PyPI","fixed":["2.12.5"],"introduced":["0"],"last_affected":[],"package":"Zope2","purl":null,"source":"GHSA-5r4x-qc7q-vj27"},{"ecosystem":"PyPI","fixed":["2.12.5"],"introduced":["0"],"last_affected":[],"package":"zope2","purl":"pkg:pypi/zope2","source":"GHSA-5r4x-qc7q-vj27"},{"ecosystem":"PyPI","fixed":["2.12.5"],"introduced":["0"],"last_affected":[],"package":"zope2","purl":"pkg:pypi/zope2","source":"PYSEC-2026-763"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2009-5144"},"products":["n/a"],"published":"2017-08-07","related":[{"cvss_score":10,"headline":"Zope DTML implementation Improper Authentication","id":"CVE-2000-0062","kev_date_added":null,"published":"2000-04-18"},{"cvss_score":8.8,"headline":"Remote Code Execution via traversal in TAL expressions","id":"CVE-2021-32674","kev_date_added":null,"published":"2021-06-08"},{"cvss_score":7.5,"headline":"Zope does not properly perform security registration for legacy names","id":"CVE-2000-1211","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Zope does not properly verify the access for objects with proxy roles","id":"CVE-2002-0170","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions","id":"CVE-2002-0688","kev_date_added":null,"published":"2003-04-02"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1227","kev_date_added":null,"published":"2002-06-25"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2001-1278","kev_date_added":null,"published":"2002-05-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Cross-site scripting in Zope ZMI pages allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2009-5145/"}