# CVE-2009-5145: Zope Cross-site scripting (XSS) vulnerability in ZMI pages

> Cross-site scripting in Zope ZMI pages allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2017
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-5r4x-qc7q-vj27, PYSEC-2026-763

## What is CVE-2009-5145?

CVE-2009-5145 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in ZMI pages that use the manage_tabs_message in Zope 2.11.4, 2.11.2, 2.10.9, 2.10.7, 2.10.6, 2.10.5, 2.10.4, 2.10.2, 2.10.1, 2.12.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2009-5145?

3 open source packages ship an affected version, including zope2 and Zope2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope2` | PyPI | All versions | 2.12.5 |
| `zope2` | PyPI | All versions | 2.12.5 |
| `Zope2` | PyPI | All versions | 2.12.5 |

Products: Zope Zope.

## How do I fix CVE-2009-5145?

Upgrade zope2 to 2.12.5 or later.

## Is CVE-2009-5145 being exploited?

There is no known exploitation of CVE-2009-5145 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2000-0062](https://insights.sbomify.com/CVE-2000-0062/): Zope DTML implementation Improper Authentication (critical 10.0)
- [CVE-2021-32674](https://insights.sbomify.com/CVE-2021-32674/): Remote Code Execution via traversal in TAL expressions (high 8.8)
- [CVE-2000-1211](https://insights.sbomify.com/CVE-2000-1211/): Zope does not properly perform security registration for legacy names (high 7.5)
- [CVE-2002-0170](https://insights.sbomify.com/CVE-2002-0170/): Zope does not properly verify the access for objects with proxy roles (high 7.5)
- [CVE-2002-0688](https://insights.sbomify.com/CVE-2002-0688/): ZCatalog plug-in for Zope allows anonymous users to bypass access restrictions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2009-5145 and fix it if it is affected.

What it is: CVE-2009-5145 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2009-5145 in the wild and no public exploit code.

Affected packages and fixed versions:
- zope2 (PyPI): affected all versions; fixed in 2.12.5
- zope2 (PyPI): affected all versions; fixed in 2.12.5
- Zope2 (PyPI): affected all versions; fixed in 2.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2009-5145/ (Markdown: https://insights.sbomify.com/CVE-2009-5145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2009-5145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2009-5145
- OSV: https://osv.dev/vulnerability/CVE-2009-5145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2009-5145/
Summaries are generated and may contain mistakes; the official description above is the record.
