CVE-2010-0156 Puppet arbitrary files overwrite via a symlink attack
Local attackers can overwrite arbitrary files via symlink attacks on temporary files, potentially compromising system integrity.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2010-0156?
CVE-2010-0156 is a low-severity path traversal vulnerability in n/a, published on 3 Mar 2010. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Puppet 0.24.x before 0.24.9 and 0.25.x before 0.25.2 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/daemonout, (2) /tmp/puppetdoc.txt, (3) /tmp/puppetdoc.tex, or (4) /tmp/puppetdoc.aux temporary file.
Weakness: CWE-59
Which versions are affected by CVE-2010-0156?
4 open source packages ship an affected version, including puppet. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | From 0.24.0 | 0.24.9 |
puppet RubyGems | From 0.24.0 | 0.24.9 |
puppet RubyGems | From 0.25.0 | 0.25.2 |
puppet RubyGems | From 0.25.0 | 0.25.2 |
Products include Puppet Puppet.
How do I fix CVE-2010-0156?
Upgrade puppet to a fixed version for your release line: 0.24.9 or 0.25.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2010-0156 being exploited?
There is no known exploitation of CVE-2010-0156 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2010-0156, GHSA-vrh7-99jh-3fmm.