CVE-2010-0668 MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration
Unspecified vulnerability in MoinMoin Wiki allows potential compromise when specific non-default features like XMLRPC or OpenID are enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2010-0668?
CVE-2010-0668 is a medium-severity vulnerability in n/a, published on 26 Feb 2010. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Unspecified vulnerability in MoinMoin 1.5.x through 1.7.x, 1.8.x before 1.8.7, and 1.9.x before 1.9.2 has unknown impact and attack vectors, related to configurations that have a non-empty superuser list, the xmlrpc action enabled, the SyncPages action enabled, or OpenID configured.
Which versions are affected by CVE-2010-0668?
5 open source packages ship an affected version, including moin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moin PyPI | From 1.5 | 1.8.7 |
moin PyPI | From 1.5 | 1.8.7 |
moin PyPI | From 1.8 | 1.8.7, 1.9.2 |
moin PyPI | From 1.9 | 1.9.2 |
moin PyPI | From 1.9 | 1.9.2 |
Products include Moinmo Moinmoin.
How do I fix CVE-2010-0668?
Upgrade moin to a fixed version for your release line: 1.8.7 or 1.9.2.
Is CVE-2010-0668 being exploited?
There is no known exploitation of CVE-2010-0668 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2020-15275 malicious SVG attachment causing stored XSS vulnerability in MoinMoin
- CVE-2009-4762 MoinMoin Improper Access Control vulnerability
- CVE-2010-0669 MoinMoin improper sanitizes user profiles
- CVE-2010-0717 MoinMoin has improper default configuration
- CVE-2008-6603 MoinMoin Access Restrictions Bypassed due to improper ACL enforcement
Sources
Also known as GHSA-574f-mh6m-c6qm, PYSEC-2010-15.