# CVE-2010-0668: MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration

> Unspecified vulnerability in MoinMoin Wiki allows potential compromise when specific non-default features like XMLRPC or OpenID are enabled.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2010
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-574f-mh6m-c6qm, PYSEC-2010-15

## What is CVE-2010-0668?

CVE-2010-0668 is a medium-severity vulnerability in n/a, published on 26 Feb 2010. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Unspecified vulnerability in MoinMoin 1.5.x through 1.7.x, 1.8.x before 1.8.7, and 1.9.x before 1.9.2 has unknown impact and attack vectors, related to configurations that have a non-empty superuser list, the xmlrpc action enabled, the SyncPages action enabled, or OpenID configured.

## Which versions are affected by CVE-2010-0668?

5 open source packages ship an affected version, including moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | From 1.5 | 1.8.7 |
| `moin` | PyPI | From 1.5 | 1.8.7 |
| `moin` | PyPI | From 1.8 | 1.8.7, 1.9.2 |
| `moin` | PyPI | From 1.9 | 1.9.2 |
| `moin` | PyPI | From 1.9 | 1.9.2 |

Products: Moinmo Moinmoin.

## How do I fix CVE-2010-0668?

Upgrade moin to a fixed version for your release line: 1.8.7 or 1.9.2.

## Is CVE-2010-0668 being exploited?

There is no known exploitation of CVE-2010-0668 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15275](https://insights.sbomify.com/CVE-2020-15275/): malicious SVG attachment causing stored XSS vulnerability in MoinMoin (high 8.7)
- [CVE-2009-4762](https://insights.sbomify.com/CVE-2009-4762/): MoinMoin Improper Access Control vulnerability (high 7.5)
- [CVE-2010-0669](https://insights.sbomify.com/CVE-2010-0669/): MoinMoin improper sanitizes user profiles (high 7.5)
- [CVE-2010-0717](https://insights.sbomify.com/CVE-2010-0717/): MoinMoin has improper default configuration (high 7.5)
- [CVE-2008-6603](https://insights.sbomify.com/CVE-2008-6603/): MoinMoin Access Restrictions Bypassed due to improper ACL enforcement (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2010-0668 and fix it if it is affected.

What it is: CVE-2010-0668 is a medium-severity vulnerability in n/a, published on 26 Feb 2010. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2010-0668 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected from 1.5; fixed in 1.8.7
- moin (PyPI): affected from 1.5; fixed in 1.8.7
- moin (PyPI): affected from 1.8; fixed in 1.8.7, 1.9.2
- moin (PyPI): affected from 1.9; fixed in 1.9.2
- moin (PyPI): affected from 1.9; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2010-0668/ (Markdown: https://insights.sbomify.com/CVE-2010-0668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2010-0668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2010-0668
- OSV: https://osv.dev/vulnerability/CVE-2010-0668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2010-0668/
Summaries are generated and may contain mistakes; the official description above is the record.
