CVE-2010-0669 MoinMoin improper sanitizes user profiles
Insufficient sanitization in user profiles allows attackers to inject malicious scripts, potentially compromising user sessions or data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2010-0669?
CVE-2010-0669 is a high-severity cross-site scripting vulnerability in n/a, published on 26 Feb 2010. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
MoinMoin before 1.8.7 and 1.9.x before 1.9.2 does not properly sanitize user profiles, which has unspecified impact and attack vectors.
Which versions are affected by CVE-2010-0669?
5 open source packages ship an affected version, including moin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moin PyPI | All versions | 1.8.7, 1.9.2 |
moin PyPI | All versions | 1.8.7 |
moin PyPI | All versions | 1.8.7 |
moin PyPI | From 1.9 | 1.9.2 |
moin PyPI | From 1.9 | 1.9.2 |
Products include Moinmo Moinmoin.
How do I fix CVE-2010-0669?
Upgrade moin to a fixed version for your release line: 1.8.7 or 1.9.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2010-0669 being exploited?
There is no known exploitation of CVE-2010-0669 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2020-15275 malicious SVG attachment causing stored XSS vulnerability in MoinMoin
- CVE-2009-4762 MoinMoin Improper Access Control vulnerability
- CVE-2010-0717 MoinMoin has improper default configuration
- CVE-2010-0668 MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration
- CVE-2008-6603 MoinMoin Access Restrictions Bypassed due to improper ACL enforcement
Sources
Also known as GHSA-977v-29j9-9rxc, PYSEC-2010-2.